Sign features in PDF editor and Dropbox Mobile might not be working for some users.

Incident Report for Dropbox Sign and Fax

Resolved

This incident has been resolved.
Posted Aug 03, 2025 - 22:20 PDT

Investigating

Sign features in PDF editor and Dropbox Mobile might not be working for some users. We’re working to fix the problem as quickly as we can.
Posted Aug 03, 2025 - 21:44 PDT
This incident affected: Core (Send signature requests) and Web (Document signing through Dropbox Sign and Fax).