Excessive site response times
Incident Report for HelloSign / HelloFax
Resolved
The fix is working as expected, response times have recovered and backlogs are mostly processed. We apologize for the problems of the last week.
Posted 5 months ago. Feb 25, 2019 - 10:10 PST
Identified
We are implementing a fix to address the issue. Response times are improving.
Posted 5 months ago. Feb 25, 2019 - 09:58 PST
Investigating
We are experiencing an unexpected re-occurrence of the incident from last Wednesday. Site and API response times for HelloFax and HelloSign are very slow. Document generation for HelloWorks is also affected.
Posted 5 months ago. Feb 25, 2019 - 09:30 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, and HelloSign API.