Document conversion backlog
Incident Report for HelloSign / HelloFax
Resolved
We are recovered from the event and are no longer experiencing delays.
Posted Jul 29, 2020 - 08:25 PDT
Update
We are working on our backlogs. Users of our Embedded Signing feature should no longer be seeing delays.
Posted Jul 29, 2020 - 08:15 PDT
Identified
The issue has been identified, we are working with a core provider now for a resolution. Document conversions should be restored very shortly. Signature request delivery and document finalization remains slow.
Posted Jul 29, 2020 - 07:47 PDT
Investigating
We are currently experiencing a backlog of document conversions, which impacts our document editor. This impacts both HelloFax and HelloSign.
Posted Jul 29, 2020 - 07:31 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.