Some workflows in Forms were not completing as expected for some users
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 13:50 PDT
Update
We are continuing to actively monitor the fix. Thanks for your patience.
Posted Nov 02, 2023 - 08:47 PDT
Monitoring
Some workflows in Forms were not completing as expected for some users. We identified the issue and a fix has been implemented. We are actively monitoring the fix.
Posted Nov 01, 2023 - 09:20 PDT
This incident affected: Core (Form sending through Dropbox Forms) and API (API callbacks from Dropbox Forms).