We are currently investigating performance problems with our site and API endpoints

Incident Report for Dropbox Sign, Fax, and Forms

Resolved

This incident has been resolved.
Posted Feb 01, 2024 - 14:32 PST

Update

We are continuing to monitor for any further issues.
Posted Feb 01, 2024 - 14:20 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2024 - 09:03 PST

Investigating

We are currently investigating performance problems with our site and API endpoints. The site is operational, but performing outside of our expectations. Thank you for your patience while we work to resolve this issue.
Posted Feb 01, 2024 - 07:55 PST
This incident affected: API (API callbacks from Dropbox Sign, API callbacks from Dropbox Forms) and Web (Fax sending through Dropbox Fax).