Delayed email deliverability
Incident Report for HelloSign / HelloFax
Resolved
The implemented measures to improve email delivery times have resolved the issues for users experiencing delays.
Posted Apr 11, 2022 - 10:15 PDT
Update
We have implemented several measures to improve email delivery times for users experiencing delays and have begun seeing gradual improvements. We expect improvements to continue over the next few days.
Posted Mar 30, 2022 - 15:06 PDT
Update
We continue to experience isolated delays in email deliverability to certain email service providers, generally less than 15 minutes. We continue to monitor email delivery rates and will continue to update here as the situation improves.
Posted Mar 22, 2022 - 17:05 PDT
Monitoring
We are currently experiencing delays in email deliverability to certain email service providers. We are monitoring email delivery rates and will update here as the situation improves.
Posted Mar 21, 2022 - 19:15 PDT
Investigating
We are currently experiencing major delays in email deliverability and are working to resolve the issue.
Posted Mar 21, 2022 - 16:43 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.