HelloWorks downtime
Incident Report for HelloSign / HelloFax
Resolved
Incident was resolved at 8:12am PST. We apologize for any inconvenience this has caused.
Posted Nov 09, 2020 - 16:04 PST
Monitoring
We have fixed the downtime issue, and will continue to monitor for a short time before declaring this resolved.
Posted Nov 09, 2020 - 08:17 PST
Investigating
We are currently investigating unplanned downtime for HelloWorks
Posted Nov 09, 2020 - 07:35 PST
This incident affected: HelloWorks.