Sign may be unavailable for some users

Incident Report for Dropbox Sign, Fax, and Forms

Resolved

This incident has been resolved.
Posted May 01, 2025 - 19:11 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 01, 2025 - 18:29 PDT

Update

We are continuing to investigate this issue.
Posted May 01, 2025 - 15:38 PDT

Investigating

Sign may be unavailable for some users. We’re having some trouble with our services currently. We’re working to fix the problem as quickly as we can.
Posted May 01, 2025 - 14:54 PDT
This incident affected: Core (Send signature requests, Form sending through Dropbox Forms, Finished document delivery, Receive faxes), Web (Document signing through Dropbox Sign and Fax, Form filling through Dropbox Forms, Fax sending through Dropbox Fax, Embedded signing through Dropbox Sign), and API (API callbacks from Dropbox Sign, API callbacks from Dropbox Forms).