Slowdown in document finalization
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
The backlog has cleared. Service should be back to normal.
Posted Feb 17, 2020 - 08:04 PST
Update
The source of the slowdown has been removed. We are working through a backlog of documents, so the perceived delay in document finalization should be getting shorter. We expect full recovery in 15 to 25 minutes.
Posted Feb 17, 2020 - 07:46 PST
Identified
We started experiencing a major slowdown in document finalization staring about 15:10 UTC. The cause has been identified, and a fix is in process. Thank you for your patience.
Posted Feb 17, 2020 - 07:27 PST