HelloSign Partial Outage
Incident Report for HelloSign / HelloFax
Resolved
Thank you for your patience, the incident has been resolved.
Posted Feb 16, 2022 - 17:02 PST
Monitoring
A fix is in place and we are monitoring performance.
Posted Feb 16, 2022 - 16:27 PST
Identified
We have identified an issue leading to degraded performance. Resolution is in progress.
Posted Feb 16, 2022 - 16:23 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.