Degraded service
Incident Report for HelloSign / HelloFax
Resolved
Systems are performing well, and performance has returned to normal. This incident is resolved.
Posted Jan 20, 2021 - 11:58 PST
Monitoring
The delays appear to be resolved, we are monitoring the situation to ensure performance stays normal.
Posted Jan 20, 2021 - 11:43 PST
Investigating
We’re currently experiencing degraded services on our HelloSign and HelloFax platforms. Service is operational but may be degraded in quality. We are actively working on a resolution and will update you as soon as possible. We appreciate your patience as our team urgently works on this!
Posted Jan 20, 2021 - 11:25 PST
This incident affected: HelloSign, HelloFax, and HelloSign API.