We’re investigating reports of degraded performance.

Incident Report for Dropbox Sign and Fax

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 19:36 PDT

Investigating

We’re investigating reports of degraded performance. Our engineering team is triaging and will share updates as we learn more.
Posted Apr 20, 2026 - 19:17 PDT