Email delivery delays
Incident Report for HelloSign / HelloFax
Resolved
We are no longer seeing significant delays of email for HelloSign traffic. HelloFax and HelloWorks were never affected.
Posted Jun 21, 2022 - 20:36 PDT
Update
Certain email providers are continuing to see mail delivery delays, but Google properties such as Gmail and Google Apps are delivering normally.
Posted Jun 21, 2022 - 15:39 PDT
Monitoring
We are currently experiencing delays with HelloSign email delivery to specific providers and are working to resolve the issue. HelloFax and HelloWorks email delivery is not affected.
Posted Jun 21, 2022 - 12:14 PDT
This incident affected: HelloSign.