Connectivity Issues
Incident Report for HelloSign / HelloFax
Resolved
The incident has been resolved. Thank you for your patience.
Posted Dec 22, 2021 - 06:29 PST
Update
The incident is resolved. Thank you for your patience.
Posted Dec 22, 2021 - 06:29 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 22, 2021 - 05:44 PST
Monitoring
Services are being restored. We are monitoring the recovery.
Posted Dec 22, 2021 - 05:43 PST
Investigating
HelloSign is experiencing an outage. We are currently investigating the issue.
Posted Dec 22, 2021 - 04:58 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.