Delayed Document Processing
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 13:35 PDT
Update
Document processing is no longer delayed, continuing monitoring.
Posted Mar 16, 2020 - 13:06 PDT
Monitoring
The issue is clearing. However, we are still monitoring the situation.
Posted Mar 16, 2020 - 12:53 PDT
Update
We are continuing to investigate this issue.
Posted Mar 16, 2020 - 12:29 PDT
Investigating
We're experiencing heavy load and users may experience delayed document processing.
Posted Mar 16, 2020 - 12:19 PDT
This incident affected: HelloSign and HelloFax.