E-mail Provider Outage
Incident Report for HelloSign / HelloFax
Resolved
This incident is resolved.
Posted Jun 09, 2022 - 13:09 PDT
Monitoring
Our e-mail provider is reporting outbound delivery as recovered. Customers should be receiving e-mail notifications as expected. We will continue to monitor.
Posted Jun 09, 2022 - 09:13 PDT
Update
We are continuing to monitor the progress from our provider. We will post another update shortly.
Posted Jun 09, 2022 - 09:03 PDT
Update
Our provider is continuing to work on a fix for this issue.
Posted Jun 09, 2022 - 08:29 PDT
Identified
Our e-mail provider is experiencing an outage, and customers may be not be receiving e-mail notifications. They are actively addressing this and we are monitoring. We apologize for the inconvenience and will post another update shortly.
Posted Jun 09, 2022 - 08:27 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.