Dropbox Sign is experiencing an outage.

Incident Report for Dropbox Sign and Fax

Resolved

We're back! Dropbox Sign should be up and running. Thanks for bearing with us.
Posted Jan 02, 2026 - 15:25 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 02, 2026 - 13:50 PST

Investigating

Update: We're getting closer to a solution. Our engineers are working to fix this problem.
Posted Jan 02, 2026 - 12:13 PST
This incident affected: Core (Send signature requests, Finished document delivery, Receive faxes), Web (Document signing through Dropbox Sign and Fax, Fax sending through Dropbox Fax, Embedded signing through Dropbox Sign), API (API callbacks from Dropbox Sign), and Integrations (Salesforce, HubSpot).