Document upload performance issues
Incident Report for HelloSign / HelloFax
Resolved
The faxing backlog appears to be fully caught up.
Posted 25 days ago. Sep 24, 2019 - 09:29 PDT
Monitoring
The inbound faxing issue has been resolved. We are currently processing a backlog, but it should finish quickly.
Posted 25 days ago. Sep 24, 2019 - 09:12 PDT
Identified
Site performance and document uploads have returned to normal latencies. Inbound faxing remains an issue.
Posted 25 days ago. Sep 24, 2019 - 08:33 PDT
Update
During this investigation we have discovered our inbound faxing provider is having an outage. Inbound faxes are not arriving, or are arriving very slowly.
Posted 25 days ago. Sep 24, 2019 - 08:31 PDT
Investigating
We are currently experiencing large slowdowns in handling document uploads. We are investigating the cause.
Posted 25 days ago. Sep 24, 2019 - 08:13 PDT
This incident affected: HelloSign, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.