Inbound hellofax email may be bouncing
Incident Report for HelloSign / HelloFax
Resolved
We believe that incoming email to HelloFax should no longer bounce, and service is restored. This is resolved.
Posted Dec 18, 2019 - 16:36 PST
Monitoring
Starting about 22:00 UTC and running to around 22:50 UTC email inbound to hellofax.com is likely to have bounced with a status-code preventing retries. There may be slow bounces now, but they should be tapering off. We understand the nature of the problem and it is resolved, but consistency is eventual in some areas.

HelloSign and HelloWorks email streams are unaffected. Outbound email is also unaffected.
Posted Dec 18, 2019 - 15:44 PST
This incident affected: HelloFax.