Delays in document processing
Incident Report for HelloSign / HelloFax
Resolved
The backlog has processed and site responsiveness has returned to normal.
Posted Apr 21, 2020 - 09:44 PDT
Update
A fix is in place, and we are processing our backlog. We expect full recovery of the document backlog and site performance within 15 minutes.
Posted Apr 21, 2020 - 09:34 PDT
Monitoring
We are currently experiencing delays in document operations, such as uploading for editing and finalizing after the last signature. The problem is with a vendor, we are monitoring the situation. Once the vendor problem is resolved, we expect the backlog of document operations to clear fairly quickly.
Posted Apr 21, 2020 - 09:19 PDT
This incident affected: HelloSign, HelloFax, and HelloSign API.