HelloSign outage recurrence
Incident Report for HelloSign / HelloFax
Resolved
This issue has been resolved. Thank you for your patience.
Posted Dec 22, 2021 - 19:42 PST
Monitoring
The site is operational and we will continue to monitor performance.
Posted Dec 22, 2021 - 07:47 PST
Investigating
We are investigating the issue to ascertain the cause.
Posted Dec 22, 2021 - 07:43 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.