Inbound Fax Backlog
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved by our inbound fax provider.
Posted Apr 20, 2021 - 22:44 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2021 - 22:43 PDT
Identified
Our inbound fax provider is working on fixing the issue preventing inbound fax delivery.
Posted Apr 20, 2021 - 17:26 PDT
This incident affected: HelloFax.