Site responsiveness issues
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 16:14 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 17, 2020 - 15:09 PST
Update
Systems have returned to normal operation.
Posted Nov 17, 2020 - 15:09 PST
Update
Fixing this issue is taking longer than expected. Our engineers are working on the problem and HelloSign should be back up soon.
Posted Nov 17, 2020 - 13:47 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2020 - 11:52 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 17, 2020 - 11:10 PST
Monitoring
We have implemented a fix and we are monitoring site performance.
Posted Nov 17, 2020 - 10:51 PST
Investigating
We are investigating reports of site responsiveness problems.
Posted Nov 17, 2020 - 10:38 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.