Delayed Document & Upload Processing
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 10:41 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2020 - 10:19 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2020 - 09:36 PDT
Investigating
We are currently investigating this issue.
Posted Jul 17, 2020 - 08:54 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.