Some signature requests with group signers are missing fields
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
This incident has been resolved.
Posted Aug 21, 2023 - 15:35 PDT
Investigating
We are currently experiencing some issues with group signers and signature requests. Signature requests that do not use the group signer functionality are not impacted. We are actively investigating this and will update the status page as we learn more. Thank you for your patience.
Posted Aug 21, 2023 - 12:04 PDT
This incident affected: Web (Document signing through Dropbox Sign and Fax) and Core (Finished document delivery).