Site performance problems
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Oct 13, 2020 - 11:51 PDT
Monitoring
Site response-time is returning to normal. We are continuing to monitor the system while our backlog processes.
Posted Oct 13, 2020 - 09:51 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 13, 2020 - 09:44 PDT
Identified
We have identified the root cause and are deploying a fix.
Posted Oct 13, 2020 - 07:17 PDT
Investigating
Site performance slow we are investigating causes.
Posted Oct 13, 2020 - 06:24 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, and HelloSign API.