Intermittent slowness and degraded signing experience.
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Dec 16, 2019 - 11:30 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 16, 2019 - 10:21 PST
This incident affected: HelloSign, HelloFax, and HelloSign API.