Delays in document finalization
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
This incident has been resolved.
Posted Aug 29, 2022 - 14:37 PDT
Monitoring
Document delivery should be back to normal.
Posted Aug 29, 2022 - 10:04 PDT
Update
We are still investigating the root cause of the issue, and will give an update once we have more information.
Posted Aug 29, 2022 - 08:57 PDT
Investigating
We are investigating reports of delays in document delivery after the final signature is gathered.
Posted Aug 29, 2022 - 06:07 PDT